use strict;
my $str = 'Good one :y. Keep going :y2
';
my $regex = qr/:y\b/mp;
my $subst = 'a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";