const regex = new RegExp(':y\\b', 'gm')
const str = `Good one :y. Keep going :y2
`;
const subst = `a`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);