package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):y\b`)
var str = `Good one :y. Keep going :y2
`
var substitution = "a"
fmt.Println(re.ReplaceAllString(str, substitution))
}