import re
regex = re.compile(r":y\b", flags=re.MULTILINE)
test_str = ("Good one :y. Keep going :y2\n")
subst = "a"
result = regex.sub(subst, test_str)
if result:
print(result)