using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":y\b";
string substitution = @"a";
string input = @"Good one :y. Keep going :y2
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}