using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+";
string input = @"Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}