const regex = /\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D+(\\d+\\.\\d+\\.\\d+)\\D+\\d{4}-\\d{4}\\D+', '')
const str = `Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}