import re
regex = re.compile(r"\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+")
test_str = "Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")