import Foundation
let pattern = #"\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}