package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+`)
var str = `Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}