re = /\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+/
str = 'Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl'
# Print the match result
str.match(re) do |match|
puts match.to_s
end