$re = '/\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+/';
$str = 'Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);