# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\([^()]*\))|([0-9]+,)\s*[0-9]+,/$1$2/gm;t' <<< "Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362"