$re = '/(\([^()]*\))|([0-9]+,)\s*[0-9]+,/m';
$str = 'Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;