#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\([^()]*\))|([0-9]+,)\s*[0-9]+,"
Local $sString = "Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)