// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\([^()]*\))|([0-9]+,)\s*[0-9]+,").unwrap();
let string = "Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}