use strict;
my $str = 'Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362';
my $regex = qr/(\([^()]*\))|([0-9]+,)\s*[0-9]+,/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";