using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\([^()]*\))|([0-9]+,)\s*[0-9]+,";
string substitution = @"$1$2";
string input = @"Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}