import Foundation
let pattern = #"(\([^()]*\))|([0-9]+,)\s*[0-9]+,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)