package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\([^()]*\))|([0-9]+,)\s*[0-9]+,`)
var str = `Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}