re = /(\([^()]*\))|([0-9]+,)\s*[0-9]+,/m
str = 'Albemarle Paper Co. v Moody (1975) 422 US 405, 425, 95 S Ct 2362'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result