# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!.+T.+)(M)/REPLACEMENT/gm;t' <<< "P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S"