const regex = /(?!.+T.+)(M)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.+T.+)(M)', 'gm')
const str = `P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S`;
const subst = `REPLACEMENT`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);