import Foundation
let pattern = #"(?!.+T.+)(M)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"REPLACEMENT"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)