$re = '/(?!.+T.+)(M)/m';
$str = 'P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S';
$subst = "REPLACEMENT";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;