#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!.+T.+)(M)"
Local $sString = "P3Y6M4DT12H30M5S" & @CRLF & _
"PT12H30M5S" & @CRLF & _
"PT12H30M5.234523S"
Local $sSubst = "REPLACEMENT"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)