using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.+T.+)(M)";
string substitution = @"REPLACEMENT";
string input = @"P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}