import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.+T.+)(M)";
final String string = "P3Y6M4DT12H30M5S\n"
+ "PT12H30M5S\n"
+ "PT12H30M5.234523S";
final String subst = "REPLACEMENT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}