use strict;
my $str = 'P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S';
my $regex = qr/(?!.+T.+)(M)/mp;
my $subst = 'REPLACEMENT';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";