re = /(?!.+T.+)(M)/m
str = 'P3Y6M4DT12H30M5S
PT12H30M5S
PT12H30M5.234523S'
subst = 'REPLACEMENT'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result