# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b([^\s]+)\b.*?)\b\2\b/$1and/gi;t' <<< "Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts"