const regex = /(\b([^\s]+)\b.*?)\b\2\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b([^\\s]+)\\b.*?)\\b\\2\\b', 'gi')
const str = `Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts`;
const subst = `$1and`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);