import Foundation
let pattern = #"(\b([^\s]+)\b.*?)\b\2\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1and"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)