use strict;
my $str = 'Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts';
my $regex = qr/(\b([^\s]+)\b.*?)\b\2\b/ip;
my $subst = '$1and';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";