$re = '/(\b([^\s]+)\b.*?)\b\2\b/i';
$str = 'Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts';
$subst = "$1and";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;