re = /(\b([^\s]+)\b.*?)\b\2\b/i
str = 'Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts'
subst = '$1and'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result