import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b([^\\s]+)\\b.*?)\\b\\2\\b";
final String string = "Green shirt green hat with blue shoes blue glasses\n"
+ "Orange colored oranges orange belts";
final String subst = "$1and";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}