using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b([^\s]+)\b.*?)\b\2\b";
string substitution = @"$1and";
string input = @"Green shirt green hat with blue shoes blue glasses
Orange colored oranges orange belts";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}