#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\b([^\s]+)\b.*?)\b\2\b"
Local $sString = "Green shirt green hat with blue shoes blue glasses" & @CRLF & _
"Orange colored oranges orange belts"
Local $sSubst = "$1and"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)