# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\n(([^"]*"){2})*[^"]*$)\n/<br>/g;t' <<< "column1rowA \"column2rowA\" column3rowA column4rowA
column1rowB column2rowB \"column3rowB
3Bcont
3Bcont
3Bcont
\" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD \"column3rowD
3Dcont\" column4rowD"