$re = '/(?!\n(([^"]*"){2})*[^"]*$)\n/';
$str = 'column1rowA "column2rowA" column3rowA column4rowA
column1rowB column2rowB "column3rowB
3Bcont
3Bcont
3Bcont
" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD "column3rowD
3Dcont" column4rowD';
$subst = "<br>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;