using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\n(([^""]*""){2})*[^""]*$)\n";
string substitution = @"<br>";
string input = @"column1rowA ""column2rowA"" column3rowA column4rowA
column1rowB column2rowB ""column3rowB
3Bcont
3Bcont
3Bcont
"" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD ""column3rowD
3Dcont"" column4rowD";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}