import re
regex = re.compile(r"(?!\n(([^\"]*\"){2})*[^\"]*$)\n")
test_str = ("column1rowA \"column2rowA\" column3rowA column4rowA\n"
"column1rowB column2rowB \"column3rowB\n"
"3Bcont\n"
"3Bcont\n"
"3Bcont\n\n"
"\" column4rowB\n"
"column1rowC column2rowC column4rowC\n"
"column1rowD column2rowD \"column3rowD\n"
"3Dcont\" column4rowD")
subst = "<br>"
result = regex.sub(subst, test_str)
if result:
print(result)