re = /(?!\n(([^"]*"){2})*[^"]*$)\n/
str = 'column1rowA "column2rowA" column3rowA column4rowA
column1rowB column2rowB "column3rowB
3Bcont
3Bcont
3Bcont
" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD "column3rowD
3Dcont" column4rowD'
subst = '<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result