use strict;
my $str = 'column1rowA "column2rowA" column3rowA column4rowA
column1rowB column2rowB "column3rowB
3Bcont
3Bcont
3Bcont
" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD "column3rowD
3Dcont" column4rowD';
my $regex = qr/(?!\n(([^"]*"){2})*[^"]*$)\n/p;
my $subst = '<br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";