#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:\|\s*|^)\d+)[ .](\d+)"
Local $sString = "|12 546,123 | AROME 53.213 | 52 321,15" & @CRLF & _
"| 2.546,123 | AROME 53 213 |152.321,15"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)