import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\|\\s*|^)\\d+)[ .](\\d+)";
final String string = "|12 546,123 | AROME 53.213 | 52 321,15\n"
+ "| 2.546,123 | AROME 53 213 |152.321,15";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}