using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\|\s*|^)\d+)[ .](\d+)";
string substitution = @"\1\2";
string input = @"|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}