$re = '/((?:\|\s*|^)\d+)[ .](\d+)/';
$str = '|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;