// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\|\s*|^)\d+)[ .](\d+)").unwrap();
let string = "|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}